GIMP-Forum 3.0

GIMP-Forum 3.0 (http://www.gimpforum.de/index.php)
-   Forumumstellung (http://www.gimpforum.de/forumdisplay.php?f=37)
-   -   Galerie nicht erreichbar (http://www.gimpforum.de/showthread.php?t=7471)

Hans 20.05.2007 22:42

Galerie nicht erreichbar
 
Was ist mit der Galerie los? Wenn ich auf Start drücke, passiert manchmal nichts und manchmal geht es.

Die beiden anderen Funktionen (Hochladen, Suchen) arbeiten bei mir einwandfrei.

Liegts an meinem System (Linux, Fedora Core 6, FF 1.5) oder am Forenserver?

TheGrudge 20.05.2007 22:44

Also bei mir gehts mit Opera 9.20 und Firefox 2.0.0.3

Leolein 20.05.2007 23:23

Du sagst es ginge mal und mal nicht. Als ich es gerade versucht habe ging es "leider" auch. ;)

Hoffe, da hat sich kein Blinker eingeschlichen ;) "geht", "geht nicht", "geht", "geht nicht".....

eRin 21.05.2007 09:55

Scotty we have a Problem:
Code:

Mem:  1008620k total,  977664k used,    30956k free,    72388k buffers
Swap:  1028144k total,    43972k used,  984172k free,  375292k cached
  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND   
 1419 mysql    15  0  140m  52m 3916 S 99.1  5.3  8674:22 mysqld

(Ausschnitt aus top)

Die Last geht wieder runter wenn die Galerie geladen ist .. mal schaun, wird dann wahrscheinlich an der Bilder Tabelle liegen ..

Danke für den Hinweis, ich bin drann ..

eRin 21.05.2007 10:52

Ok, hab die beiden bösen MySQL-Queries gefunden. Beide Queries zusammen brauchen zusammen 30 Sekunden bis diese ausgeführt. Bei 6000 Datensätzen und jede Menge MAX() COUNT() IF() SUM() gemischt mit JOINs und Gruppierungen kann das nicht gut gehen ..

Code:

Showing rows 0 - 0 (1 total, Query took 15.3798 sec)
Showing rows 0 - 4 (5 total, Query took 13.8565 sec)

Wird noch kurz dauern ..

Nachtrag: Ok die Startseite des Albums sollte wieder flutschen .. Es werden in der Auflistung unten (letze 5 Bilder) keine Ratings mehr angezeigt und zum anderen wurden 2 eher überflüssige Queries rausgeschmissen.

sn00zer 21.05.2007 15:16

Datenbankfehler Datenbankfehler
Es trat ein Problem mit der GIMP-Forum 2.0 Datenbank auf.

kam gerade, als ichs auf diesen thread hin ausprobiert hab^^

windows xp home + firefox 2.0.0.3

naranja Ó 21.05.2007 17:05

Zitat:

Zitat von sn00zer (Beitrag 63890)
Datenbankfehler Datenbankfehler
Es trat ein Problem mit der GIMP-Forum 2.0 Datenbank auf.

Bei mir kommt selbiges.
SeaMonkey 1.1.1

eRin 21.05.2007 21:02

Ups .. mein Fehler von heute morgen, ist behoben ..

Upload geht wieder, habs grad getestet.

Hans 21.05.2007 22:03

Zitat:

Zitat von eRin (Beitrag 63881)
Code:

Mem:  1008620k total,  977664k used,    30956k free,    72388k buffers
Swap:  1028144k total,    43972k used,  984172k free,  375292k cached
  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND   
 1419 mysql    15  0  140m  52m 3916 S 99.1  5.3  8674:22 mysqld


Oooohhh!! Wenn ich die Zahlen sehe, dann wird mir einiges klar. Besonders die Prozessorzeit gibt zu denken. Mein Vorschlag wäre, dass man mal hin und wieder mysqld neu startet. Nachts um drei arbeiten doch nicht so viele, außer ILL vielleicht? ;)

eRin 21.05.2007 22:19

es ist ja nicht so, dass dem ein Dauerzustand ist. Jetzt nachdem die paar Queries optimiert wurden schnurrt der MySQL-Server wieder wie ein kleines Kätzchen :)

Und ja, ich bin ein Uptime-Junky ;)


Alle Zeitangaben in WEZ +2. Es ist jetzt 09:37 Uhr.

Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.