Forum Wiki Galerie Kontakt Wie man Fragen richtig stellt. Tutorial Forum
Zurück   GIMP-Forum 3.0 > Probleme > Technische Fragen

Hinweise
Alt 18.10.2014, 18:19   #1
Asmodis
Erfahrener Benutzer
 
Benutzerbild von Asmodis
 
Registriert seit: 25.05.2009
Ort: Karlsruhe
Beiträge: 950
Standard RawTherapee Export zu Gimp -> tiff-load crasht

Hallo zusammen,

ich bin gerade am Bilder bearbeiten und habe versucht, ein Bild direkt von RawTherapee (4.1.80x64) in Gimp (2.8.14(v.1)x64) zu importieren. Leider wurde ich nach dem Start von Gimp anstatt von meinem Bild nur von ein paar Fehlermeldungen begrüßt - siehe unten. Was mich wundert ist die Fehlermeldung von script-fu.exe. Ich habe kein einziges Skript installiert.

Code:
---------------------------
script-fu.exe - Einsprungpunkt nicht gefunden
---------------------------
Der Prozedureinsprungpunkt "g_list_free_full" wurde in der DLL "C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins\script-fu.exe" nicht gefunden. 
---------------------------
Code:
---------------------------
file-tiff-load.exe - Einsprungpunkt nicht gefunden
---------------------------
Der Prozedureinsprungpunkt "gdk_win32_window_foreign_new_for_display" wurde in der DLL "C:\Program Files\GIMP 2\bin\libgimpui-2.0-0.dll" nicht gefunden. 
---------------------------
Und zu guter Letzt noch:
Code:
Plug-in crashed: "file-tiff-load.exe"
(C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins\file-tiff-load.exe)

The dying plug-in may have messed up GIMP's internal state. You may want to save your images and restart GIMP to be on the safe side.

Opening 'C:\Users\Simon\AppData\Local\Temp\_MG_5569.tif' failed: Procedure 'file-tiff-load' returned no return values
Die letzten drei Meldungen dürften zusammenhängen - tiff-load funktioniert nicht richtig, crasht deshalb und gimp bekommt das erwartete Bild nicht zurückgeliefert. Was aber Skript-Fu damit zu tun hat, bleibt mir weiterhin ein Rätsel.

Jetzt wirds aber noch komischer: zum Testen habe ich mir das betroffene Tiff mal aus dem temp-Ordner auf den Desktop geholt und per Rechtsklick "Mit Gimp öffnen" versucht zu öffnen -> tiff-load liefert den selben Fehler, die Meldung von skript-fu bleibt dieses Mal aber aus (Gimp war hier vom fehlgeschlagenen Versuch noch geöffnet). Als ich dann aber Gimp geschlossen habe und dann nochmal versucht habe, das tiff zu öffnen, ging alles Problemlos. Keine Fehlermeldung mehr und nichts.

Nächster Versuch mit dem Export aus RawTherapee -> gleiches Ergebnis wie am Anfang. Ich werde mir gleich mal mit dem Process Monitor ansehen, was RT beim Aufrufen von Gimp so alles anstellt, was Gimp nicht gefallen könnte, und gebe dann nochmal Rückmeldung.

Edit: Ich bin aus dem Process-Monitor-Log leider nicht sehr schlau geworden. Ich sehe da eigentlich nichts, was Gimp irgendwie irritieren könnte. Ich habe das Logfile dennoch mal gepackt und hier hochgeladen. Falls sich das jemand anderes mal ansehen möchte (achtung, die xml hat entpackt 170 MB).

Edit 2: ich sehe gerade: vielleicht hätte ich im Log auch die crashenden Plugins mit einbeziehen sollen - das mache ich nachher oder morgen dann nochmal

Edit 3: ich habe das ganze jetzt nochmal gemacht und dabei auch mal die Plugins mit überwacht - und habe dabei denke ich das Problem gefunden. Siehe im nächsten Post.
Angehängte Dateien
Dateityp: zip Logfile-pml.zip (1,74 MB, 181x aufgerufen)
Dateityp: zip Logfile-xml.zip (4,24 MB, 207x aufgerufen)
Dateityp: zip Logfile-xml-noStacktrace.zip (564,0 KB, 1167x aufgerufen)
__________________
Lg, Simon
GIMP 2.8.18 | Windows 10 (64Bit) "Redstone", Ubuntu 15.10

Downloads:
---> Gimp | G'MIC | Plugin-Registry <---

Gimp-Einstellungsordner: C:\Users\USERNAME\.gimp-2.8\


Geändert von Asmodis (18.10.2014 um 20:30 Uhr)
Asmodis ist offline   Mit Zitat antworten
 

Lesezeichen

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist Aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Gimp besorgen und installieren. Rebell Technische Fragen 106 28.10.2014 18:30
The GIMP 2.2.0 schumaml Neues von GIMP 8 01.07.2006 20:35
The GIMP 2.2-pre2 schumaml Neues von GIMP 11 25.01.2005 20:51
The GIMP 2.2-pre1 (Halloween Release) schumaml Neues von GIMP 2 14.11.2004 20:12


Alle Zeitangaben in WEZ +2. Es ist jetzt 15:52 Uhr.


Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.