Forum Wiki Galerie Kontakt Wie man Fragen richtig stellt. Tutorial Forum
Zurück   GIMP-Forum 3.0 > Probleme > Hilfe und Fragen

Hinweise
Alt 03.06.2018, 12:51   #1
ursa major
Erfahrener Benutzer
 
Registriert seit: 02.04.2014
Beiträge: 2.144
Standard G'MIC Film Emulation funktioniert nicht

Hallo in die Runde,

ich habe GIMP gerade auf meinem neuen Rechner (Windows 10, 64 Bit, i7, 8 GB RAM) installiert, das G'MIC-Plugin dazu und schließlich noch die externen Daten, die man sich aus G'MIC heraus dafür runterladen kann, und die, soweit ich weiß, aus Voreinstellungen für die Film emulation bestehen. Funktioniert alles, soweit ich das bisher feststellen konnte. Nur die G'MIC Film emulation nicht:
Zitat:
***Error in ./fx_emulate_film_bw_preview/gui_split_preview/*repeat/(...)/*if/*repeat/*if/local/***gmic::fopen():Failed to open file 'C:\Users\my name\AppData\Roaming\gmic\gmic_film_cluts.gmz'with mode 'wb'.
Die in der Fehlermeldung genannte Datei "gmic_film_cluts.gmz" ist in der G'MIC-Installation und auch in den externen Daten vorhanden, die ich nachgeladen habe. Insofern ist sie also doppelt. Ich habe es auch schon versucht indem ich je eine der beiden gelöscht und die nachgeladene in den Installationsordner verpflanzt habe, aber auch das hat nicht gefunzt. Ist das nur bei mir so oder hat noch jemand dieses Problem? Und vielleicht sogar eine Lösung? Ansonsten müsste ich es wohl mit einem Bug-Report versuchen.


By the way, unter GIMP 2.10 kann man nun auch die Bildansicht (Leinwand) drehen (ohne dass sich das Bild selbst dabei ändert), wie mir gerade aufgefallen ist. Coole Sache, auf die ich schon lange gehofft habe. Sehr hilfreich beim Malen und Retouchieren. Und handlicher als in Photoshop. Man muss nur die mittlere Maustaste (respektive die Leertaste) und die Shift-Taste gedrückt halten. Dann kann man mit der Maus drehen.


Edit: Auch ohne die nachgeladenen externen Daten scheint es nicht zu funktionieren.
ursa major ist offline   Mit Zitat antworten
Alt 03.06.2018, 19:39   #2
gedon
Erfahrener Benutzer
 
Registriert seit: 15.01.2012
Beiträge: 601
Standard

Kann ich nicht bestätigen. Auf meinem i5 Schlepptop klappt die G'Mic Filmemulation einwandfrei und ohne Fehlermeldung.
gedon ist offline   Mit Zitat antworten
Alt 03.06.2018, 20:04   #3
ursa major
Erfahrener Benutzer
 
Registriert seit: 02.04.2014
Beiträge: 2.144
Standard

Hast Du da Windows 10 laufen? Auf meinem alten Rechner mit Win 7, 64 Bit läufts auch korrekt. Benutze die Film Emulation recht oft. Werde G'MIC nochmal komplett neu installieren.

Leider gibt es da auch noch ein paar andere Problemfälle. Der neue Fraktalspur-Filter lässt GIMP abstürzen sobald man die Tiefe verstellt und der "Nebel"-Filter (Menü "Dekoration") crasht wenn ich die Farbe wechseln will. In G'MIC gab es auch noch einen weiteren Problemfilter. Erinnere aber gerade nicht welcher es war. Die Vordergundauswahl funzt immerhin auf meinem neuen Rechner. Wenn auch recht langsam. Offensichtlich eine rechenintensive Angelegenheit.
ursa major ist offline   Mit Zitat antworten
Alt 03.06.2018, 21:19   #4
gedon
Erfahrener Benutzer
 
Registriert seit: 15.01.2012
Beiträge: 601
Standard

Win 10, klar.

Beim Fraktalfilter habe ich ein anderes Verhalten, da stürzt Gimp ab, wenn ich X1 verstelle. Tiefe ist dagegen kein Problem.
Nebel: gleicher Absturz wie bei dir.

Was mich im Moment etwas mehr stört sind die unterschiedlichen Empfindlichkeiten: so ist Belichtung über den Schieber recht aggressiv, während Sättigung eher gemächlich zu Werke geht. Aber das sind eher Kleinigkeiten.

Der automatische Weißabgleich ist auch eher unbrauchbar. Unvorhersehbare Resultate. Da wird nicht nur die Farbtemperatur verändert, sondern außerdem noch die Luminanz.

Insgesamt läuft 2.10.2 unter Win 10 ganz brauchbar und besser als befürchtet.

Nur den Resynthesizer habe ich noch nicht zum laufen gebracht. Keine Fehlermeldung, aber erscheint auch nirgendwo.

Wäre auch nicht schlecht, wenn Gimp eine Funktion "bearbeiten mit ... " hätte. Dann könnte man die Objektivkorrektur von darktable auch für jpg oder png nutzen. RAW Bilder werden von Gimp ja automatisch in darktable geöffnet, wenn installiert. Werd demnächst mal mit Shellout probieren.

Noch etwas unbequem: wäre praktisch, wenn man Quelle und Zielordner separat festlegen könnte. So muß man tricksen, um die Anzahl der Klicks auf ein erträgliches Maß zu reduzieren. Bei 3.500 Urlaubsbildern macht das keinen Spaß.
gedon ist offline   Mit Zitat antworten
Alt 03.06.2018, 22:19   #5
ursa major
Erfahrener Benutzer
 
Registriert seit: 02.04.2014
Beiträge: 2.144
Standard

Stimmt, bei X1 stürzt mir der Fraktalspur-Filter samt GIMP auch ab, nur etwas später. Ebenso bei X2, Y1 und wohl allen anderen Reglern. Es scheint mit der Stärke der Einstellung zu tun zu haben. Wenn ich die Tiefe nur gering verstelle stürzt GIMP nicht sofort ab. Die Erkenntnis hilft aber auch nichts, weil man so mit dem Filter nichts anfangen kann.

Eigenartig ist auch das Verhalten des Filters "Sättigung". Der höchste Wert den man da einstellen kann ist offenbar 10,000 (wobei eine solche Sättigung wohl niemand haben will). Aber der Balken erreicht den rechten Rand schon bei etwa 2,000. Weiter ziehen kann man trotzdem, der Balken stellt es nur nicht dar.

Auch die Filter im Menü "Farben">"Dynamikkompression" reagieren extrem zögerlich.

Da scheint bei den neuen Funktionen noch einiger Justierungsbedarf zu sein.
ursa major ist offline   Mit Zitat antworten
Alt 13.06.2018, 19:02   #6
ursa major
Erfahrener Benutzer
 
Registriert seit: 02.04.2014
Beiträge: 2.144
Standard

Ich aktualisiere hier mal kurz. Die Ursache meines Problems scheint weder mit G'MIC, noch mit GIMP direkt zu tun haben, sondern mit Windows 10 und mir. Mein Name enthält nämlich einen Umlaut, und da ich mich beim Installieren von Win 10 von all dem neuen Firlefanz wie Microsoft-Konto, Cortana und der Flut der dreisten Big-Brother-Funktionen schier überrumpelt fühlte, habe ich versehentlich meinen Realname zum Benutzernamen gemacht, ohne mir dessen bewusst zu sein. Nun kann man zwar sein Nutzerkonto problemlos umbenennen, der Benutzerordner auf der Systempartition bleibt davon aber unbeeindruckt. Und weil die Filter der Film Emulation nunmal immer in diesem Benutzerordner liegen scheitert G'MIC immer an diesem vermaledeiten Umlaut.Wenn irgendeiner eine Idee hat wie ich den da weg bekommen kann ohne Windows nochmal komplett neu installieren zu müssen - ich wäre wirklich dankbar. Googlen hat mir da bislang nicht geholfen.
ursa major ist offline   Mit Zitat antworten
Alt 13.06.2018, 21:33   #7
ence
Erfahrener Benutzer
 
Registriert seit: 21.08.2014
Beiträge: 303
Standard

Das hier: http://explipedia.de/benutzerordner-...-aber-richtig/ vielleicht mal probieren.
ence ist offline   Mit Zitat antworten
Alt 13.06.2018, 22:41   #8
ursa major
Erfahrener Benutzer
 
Registriert seit: 02.04.2014
Beiträge: 2.144
Standard

Hi ence!

Danke zunächst mal für den Tipp! Ich habe es gerade mal probiert, bin mir aber nicht sicher ob es funktioniert hat. Jedenfalls klappte es nicht reibungslos. Zunächst konnte ich mich unter meinem Admin-Konto nicht mehr anmelden. Zum Glück hatte ich aber noch ein Unterkonto, wo erstaunlicherweise mein Admin-Kennwort funktionierte und mit dem ich den Registry-Eintrag wieder zurücksetzen konnte. Danach kam ich auch wieder in mein Admin-Konto. Nun stelle ich fest, dass ich sowohl den alten Benutzerordner mit dem Umlaut im Nutzernamen habe, als auch einen Benutzerordner mit dem neuen Namen. Ob ich damit irgendwas anfangen kann muss ich aber morgen abend ausknobeln. Muss morgen früh raus. So ganz geheuer ist mir das nicht. Vielleicht funktioniert das unter Windows 10 einfach nicht. Zur Not habe ich aber einen Wiederherstellungspunkt, den ich vorher erstellt hatte.

Jedenfalls danke für den Tipp. Einen Versuch war es auf jeden Fall wert. Mehr dann voraussichtlich morgen abend.
ursa major ist offline   Mit Zitat antworten
Alt 02.07.2018, 15:33   #9
ursa major
Erfahrener Benutzer
 
Registriert seit: 02.04.2014
Beiträge: 2.144
Standard

Das Thema erkläre ich jetzt mal für abgeschlossen. Ich habe letztendlich Windows doch komplett neu installiert, dieses Mal besser aufgepasst, dass der Benutzername nicht wieder einen Umlaut enthält, und es funktioniert jetzt. Vielleicht ist die Info ja für irgendjemanden nützlich.
ursa major ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist Aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
PytonFu en Gmic, Plugin PeterPKHG Skripte 3 14.09.2016 12:41
[GIMP Registry] - Film Emulation Presets with G'MIC (Similar to VSCO) Wilber GIMP 0 04.09.2013 21:03
[GIMP Registry] - B&W Channel Mixer Settings (Film Emulation) Wilber GIMP 0 05.02.2013 22:50
[GIMP Registry] - Expired Polaroid 600 Print Emulation Wilber GIMP 0 22.06.2011 22:50


Alle Zeitangaben in WEZ +2. Es ist jetzt 13:55 Uhr.


Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.