Forum Wiki Galerie Kontakt Wie man Fragen richtig stellt. Tutorial Forum
Zurück   GIMP-Forum 3.0 > Arbeiten mit Gimp > GIMP-Ressourcen > Skripte

Hinweise
Alt 18.05.2016, 01:13   #1
Yadgar
Neuer Benutzer
 
Registriert seit: 20.02.2006
Beiträge: 9
Standard GIMP hängt sich im Batchmode auf

Hi(gh)!

Ich versuche gerade, ein selbstgeschriebenes Skript

Code:
(define (script-fu-cga16-nodither image layer)
  (gimp-context-set-interpolation 3)
  (gimp-image-scale image 133 100)
  (gimp-image-convert-indexed image 0 4 16 FALSE FALSE "CGA-16")
  (gimp-context-set-interpolation 0)
  (gimp-image-scale image 960 720)
)

(script-fu-register
  "script-fu-cga16-nodither"
  "<Image>/Filters/Retro/CGA-16/cga16-nodither"
  "Konvertiert Bild in ein CGA-Bild mit 16 Farben, ohne Rasterung."
  "Jörg 'Yadgar' Bleimann"
  "Jörg 'Yadgar' Bleimann"
  "2016-05-18"
  "RGB*, GRAY*"
  SF-IMAGE    "Image" 0
  SF-DRAWABLE "Layer" 0
)

über eine längere Sequenz von Einzelbildern aus einem Video laufen zu lassen... leider verhält sich GIMP im Batchmodus merkwürdig:

yadgar@debian:/media/yadgar/video/train1-cga16-nodither$ gimp --verbose -i -b script-fu-cga16-nodither train1-0000*.png
INIT: gimp_load_config
Parsing '/home/yadgar/.gimp-2.8/unitrc'
Parsing '/etc/gimp/2.0/gimprc'
Parsing '/home/yadgar/.gimp-2.8/gimprc'
gimp_composite: verbose=no
Processor instruction sets: +mmx +sse +sse2 -3dnow -altivec -vis
INIT: gimp_initialize
INIT: gimp_real_initialize
INIT: gimp_restore
Parsing '/home/yadgar/.gimp-2.8/parasiterc'
Loading 'brush factory' data
Loading 'dynamics factory' data
Loading 'pattern factory' data
Loading 'palette factory' data
Loading 'gradient factory' data
Loading fonts
Parsing '/home/yadgar/.gimp-2.8/templaterc'
INIT: gimp_real_restore
Parsing '/home/yadgar/.gimp-2.8/pluginrc'
Starting extension: 'extension-script-fu'
Kein Interpreter angegeben, es wird der Standardinterpreter »plug-in-script-fu-eval« verwendet.
batch command executed successfully

Mehr passiert nicht - das Programm scheint sich aufgehangen zu haben, jedenfalls ändert sich an meinen Bildern nichts. Was mache ich falsch?

Bis bald im Khyberspace!

Yadgar
Yadgar ist offline   Mit Zitat antworten
 

Lesezeichen

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist An.
Smileys sind An.
[IMG] Code ist An.
HTML-Code ist Aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
The GIMP 2.2-pre1 (Halloween Release) schumaml Neues von GIMP 2 14.11.2004 19:12


Alle Zeitangaben in WEZ +2. Es ist jetzt 07:39 Uhr.


Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.